唐山信息港

通達信黑馬必勝指標公式

更新時間:2020-05-23 08:40

{大陰線:大跌超2.3}C2:=REF(C,1);
BG:=IF((C2-C)*100/C2>=2.3,1,0) OR IF((O-C)*100/O>=5,1,0){ OR IF((H-L)*100/REF(C,1)>5,1,0)};
{第二個條件開盤價過高掉下來} BG2:=IF((H-L)*100/C2>=3.58,1,0);
BB1:=L<REF(L,1);
{賣點信號} SELL1:=BG AND BB1 ;
{大陽線:升幅超2.64}BR:=IF((C-C2)*100/C2>=2.59,1,0) OR IF((C-O)*100/O>=4.5,1,0) OR IF((C-L)*100/L>5,1,0);
{第二個條件開盤價太低升上來}{STICKLINE(BR,O,C,3,0),COLORRED;
}{以下條件記住最近一次賣出點} DAY1:=BARSLAST(SELL1);
JIA1:=REF(O,DAY1);
JIA2:=REF(O,1);
BB4:=C>JIA2;
BB2:=H>JIA1;
{買入信號} BUY1:=BR AND BB2AND BB4;
{記住最后一次買點} DAY2:=BARSLAST(BUY1);
{買賣誰先} S1:=DAY1<DAY2;
B1:=DAY2<DAY1;
{其它補充1:買點} AA2:=AMOUNT/VOL;
BB3:=L<AA2*0.9;
CC2:=(C-REF(C,1))/REF(C,1)*100>1.2;
DD2:=L<MA(C,6)*0.921;
DD1:=L<MA(C,5)*0.921;
EE2:=VOL<MA(V,5)*1.5;
FF2:=BB3 AND CC2 AND DD2 AND EE2;
老鼠倉:=BB3 AND CC2 AND DD1 AND EE2,LINETHICK0,COLOR0099FF;
DRAWTEXT(老鼠倉,L*0.97,'老鼠倉'),COLOR0099FF;
DRAWTEXT(FF2,L*0.99,'買點'),COLOR00FFFF;
{STICKLINE(FF2,H,L,0.3,0),COLOR00FFFF;
STICKLINE(FF2,O,C,3,1),LINETHICK2,COLOR00FFFF;
}{檢查買點是否成立} B4:=BARSLAST(FF2);
{底點日期} E4:=B4<5;
{5日內的線} F4:=E4 AND C>REF(C,1);
{STICKLINE(F4,H,L,0.3,0),COLOR00FFFF;
}{其它補充2:賣點} A2:=(C-REF(C,1))/REF(C,1)*100<1.02;
A3:=H>MA(C,5)*1.12;
AA:= A2 AND A3;
DRAWTEXT(AA,H*1.05,'賣點'),COLORFF0000;
{STICKLINE(AA,H,L,0.3,0),COLORFF0000;
STICKLINE(AA,H,L,3,0),COLORFF0000;
};
{補充陽光買點} VAR1:=4*SMA((CLOSE-LLV(LOW,5))/(HHV(HIGH,5)-LLV(LOW,5))*100,5,1)- 3*SMA(SMA((CLOSE-LLV(LOW,5))/(HHV(HIGH,5)-LLV(LOW,5))*100,5,1),3.2,1);
VAR2:=8;
CC:=CROSS(VAR1,VAR2);
CCC:=CROSS(VAR1,VAR2) AND H>REF(H,1) AND C>REF(C,1) ;
DRAWICON(CCC,L*0.99,1);
{STICKLINE(CC,H,L,0.3,0),COLORRED;
STICKLINE(CC,O,C,3,1),LINETHICK2,COLORRED;
}{加強買點后續升勢} CF1:=BARSLAST(CC);
{買點日期} CF2:=CF1<3;
{5日內的線} CF3:=CF2 AND C>REF(C,1);
{STICKLINE(CF3,O,C,3,0),COLOR00FFFF;
}CD:=CROSS(VAR2,VAR1);
{STICKLINE(CD,H,L,0.3,0),COLORYELLOW;
STICKLINE(CD,O,C,3,1),LINETHICK2,COLORYELLOW;
}DRAWTEXT(CD,H*1.01,'準備'),COLORYELLOW;
DRAWTEXT(CC,L*0.98,'買'),COLORFF00FF;
{輸出粉紅色的買字};
{牛窩} VAR1A:=LLV(LOW,21);
VAR2A:=HHV(HIGH,21);
AK1:=EMA((((CLOSE - VAR1A) / (VAR2A - VAR1A)) * 100),5);
AK:=EMA((((CLOSE - VAR1A) / (VAR2A - VAR1A)) * 50),13);
AB:=CROSS(AK1,AK);
DRAWTEXT((AB = 1),(LOW * 0.95),'○牛窩'),COLORYELLOW;
{大膽博、加倉、小心變盤、逃頂} VAR3AA:=IF((CLOSE>REF(CLOSE,1)),88,0);
VAR4AA:=IF(((CLOSE)/(REF(CLOSE,1))>1.05) AND ((HIGH)/(CLOSE)<1.01) AND (VAR3AA>0),91,0);
DRAWTEXT(FILTER((VAR4AA>90),45),(LOW)*(0.93),'★大膽搏 '),COLOR00FFFF;

推薦文章

收音鸡赚钱 东京快乐8开奖软件 手机真钱赌场 吉林快3走势图基本图 好彩1生肖季节走势图 涨停版股票 股票配资的流程有哪些 杠杆炒股有哪些推荐 浙江11选五开奖真准网 乐天盈股票配资平台 特马网站今晚开特马